PDA

View Full Version : Here's a cheap fix for hard to turn handlebars



01-18-2004, 01:46 PM
I just posted it on my webpage and figured I'd link it to here..


Click HERE (http://ricoracing.netfirms.com/Tips_and_tricks_page_2.htm) Sucka

red
01-18-2004, 01:50 PM
wow hes a genius:blah:

member
01-18-2004, 01:55 PM
i cant see the pics:(

01-18-2004, 03:49 PM
Originally posted by member
i cant see the pics:(

They are there. You might have to give it a minute to load. No errors in the page I checked for errors in links and there aren't any..:cool:

RiPPiNiTuP7
01-18-2004, 03:56 PM
....or you could just pile on some high quality grease and leave the washer out :o

01-18-2004, 04:06 PM
Originally posted by RiPPiNiTuP7
....or you could just pile on some high quality grease and leave the washer out :o

Thats a big Negative...:cool:



I use mobil 1 synthetic grease, which is like $12 a tube. It doesn't get any more high quality unless your gettin your grease from NASA. It might not be necessary for a stock stem but an aftermarket stem with PC on it gives it a larger diameter, there for the added small washer makes up for the difference.;) I know for a FACT it made my steering a HE11 of a lot easier..

Pappy
01-18-2004, 04:22 PM
i used this tid bit of quality info on my chrome stem...works like a champ:p

gimpbzkt400ex
01-18-2004, 04:52 PM
I have been wondering about that... cuz every since I got my 400ex... it has been a b@%^* to turn I have loosend the bolts a little.. but it didn't help... I will try that and while I am at it I am going to put some good marine grease (water proof) on it too...

dirtmomma
01-18-2004, 04:58 PM
Hummm I wonder if this or something like this would work on our mini?? It's a LEM Condor 50 & it's REALLY stiff in the steering!! Ight have to see if we could do someting like this. Good info!

Taco
01-18-2004, 05:15 PM
pfft I've done that for years:rolleyes:

01-18-2004, 06:06 PM
Originally posted by Taco
pfft I've done that for years:rolleyes:

Shut yo suasage holder:grr:

Pappy
01-18-2004, 06:10 PM
Originally posted by Rico
Shut yo suasage holder:grr:

wrong end:eek:

RiPPiNiTuP7
01-18-2004, 06:15 PM
Originally posted by Pappy
wrong end:eek:

:eek2: :eek:

member
01-18-2004, 08:12 PM
could someone do me a favor and post da pics i still cant get them to show up:(

Taco
01-18-2004, 08:19 PM
Originally posted by Pappy
wrong end:eek: :cuss: :cuss: :cuss: :cuss:

muff
01-18-2004, 08:57 PM
I just did this today when the quad was up on the stand...it made a huge difference :D

Greg Z
01-18-2004, 11:07 PM
doesnt work the site at least for me

some one post it here and put it in the FAQ section or tech articals !!!!

Bill Fuller
01-18-2004, 11:30 PM
Won't load for me dawg???

Meek
01-18-2004, 11:33 PM
I had to do this on my new Houser stem.

hondarider2006
01-19-2004, 04:13 AM
here they are for all of the people that can't see them;)

hondarider2006
01-19-2004, 04:14 AM
2

01-19-2004, 08:58 AM
can you all see my page????

Just not the pics???

Does it show a red X or what???

Bill Fuller
01-19-2004, 09:01 AM
Works now my brotha!!!

01-19-2004, 09:18 AM
Originally posted by Bill Fuller
Works now my brotha!!!

I didn't do anything to make it work...:confused:

You old guys need to update your bi-focals...:o

dirtmomma
01-19-2004, 09:32 AM
Seen it just fine, did have to hit reload once but it came up w/ all pics!!

MEL
01-19-2004, 10:07 AM
i did that to mine earlier this year, and it made a big difference. while i had it apart i drilled and tapped the bracket and put a zerk fitting in there so i don't have to remove it all the time to grease it.