PDA

View Full Version : lt80 sputters and dies



bigred50
11-07-2007, 09:51 PM
hey i am very new to the lt80, i just picked one up yesterday. so heres my problem: when i am riding it in a straight line or have all 4 tires well planted on the ground it runs fine but as soon as i go up on the 2 side wheels it sputters and dies. this doesnt happen when i am doing a wheelie, only when i'm on the side wheels. also if i take a corner hard it will sputter a little bit. the other weird thing is my choke. when the choke is pulled up (i think this means on) it runs but when the choke is pushed down (i think this should be off) it will idle for a few seconds then die. again i am very new to the lt80 and have never had a two stroke before. sorry if the questions are really stupid but i need the help :D . any ideas would be greatly appreciated. thanks again!

LT80
11-08-2007, 08:07 AM
I think you should clean the carb. :)

bigred50
11-08-2007, 11:27 PM
i cleaned my carb today and it runs much better. it now runs and drives with the choke off but has trouble idling. i have to keep tapping the throttle or it will die after a few seconds. i tired turning up my idle speed but that didnt seem to help. it idles alot better when the choke is on. is it running to lean with the choke off? if so how can i make it run more rich? again sorry for my ignorance. thanks alot :D

LT80
11-10-2007, 09:05 AM
Did you remove both jets and clean?
If the choke on makes a difference then it's in the carb, reed, or possibly a low compression problem. A compression check will eliminate that aspect (120+).