PDA

View Full Version : Front Brake Problem Help!!!!!!!



TC426EX
07-21-2004, 10:35 AM
Hopefully someone can help me out there... I just replaced the front brake pads on my quad and now the front wheels are locking up. If I pull the front brake they will just stay up against the rotor except the inside one just gets pressed harder into it. The outside one seems to be rubbing all the time or close to it if it isnt. Only the inside pad seems to be moving but it still is pretty locked into place against thr rotor unless I pry it off with a screwdriver and compress the piston. When I did take the gold allen bolts/pins out of the front that hold the pads on I did notice that the gold finish was worn off in the middle but I dont think that would have that much of an impact, plus I greased the pins before I put them back through the pads... I dont know if I am explaining this clear enough, but they didnt drag at all when the pads were shot, and now they do, and I mean BAD. I need help guys, Im trying to get this together for a race and dont want to be forced to just throw the shot pads back on for now....

Pappy
07-21-2004, 10:39 AM
what brand pads are they? ive heard of some brands being too thick and causing issues

K_Fulk
07-21-2004, 11:25 AM
If your calipers slide on the pins that hold it on the mount smoothly the pads are probly just to thick.

Once I installed rear pads and had to remove the little piece that goes over the piston to get the caliper over the rotor.

TC426EX
07-21-2004, 12:25 PM
Thanks guys, I figured it out. I got cheap pads (ferodo) and they were just too thick. I ran up and got a set of DP's in their place and Im back in business... Fortunately my friend wants my old new pads so Im not gonna be out too much money. I appreciate the help.